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Totorial for creation of an inverter cell from schematic to layout with CADENCE 
using AMS-Hitkit and hints for multi-input gates

1. Using the Linux (CentOS) environment
2. Starting CADENCE with AMS-Hitkit
3. Creating a new library
4. Schematic entry 
5. Creating a symbol and a testbench
6. Spice-Simulation using ADE XL

• Analyses selection and setup
• Using global variables
• Parametric simulation

7. Starting Layout XL
• Generate layout from schematic
• The layer window
• Wires, vias/contacts, wells

8. Design rule check
9. Layout versus schematic check (LVS)
10. Parasitic extraction (QRC)
11. Simulation of the extracted model (Post-layout simulation)

Cadence + AMS-Hitkit
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Some UNIX-commands

pwd print working directory
ls,  ls –alsi, ls dir list
cd  ->  cd /~/ske ->  cd  ./ske change directory
mkdir newdir make directory
cp , cp -r, cp -p copy files/directories (recursive, preserve attributes)
mv move or rename directories
chmod,  chmod –R   chmod 744 file change file mode bits (security) -> -R recursive
grep filter for pattern
use of | for pipeline  ->   ls | grep pattern use command output as input for next command
rm, rm –r remove/delete
rmdir remove directory
cat  file show file at standard output
man cmd show manual of cmd

We use CentOS-Linux (Free version "Community Enterprise OS" of RedHat), because Cadence supports RedHat or Suse.
We use the Kornshell (ksh), because it is the standard shell at ITMZ Uni Rostock.

Or Right-Mouse on Background and select "Open Terminal"

Move icon to desktop for easy use

Unix-command to remove Cadence lock files (Close all Cadence programs before!) : find ~/  -name  "*.cdslck" -exec  rm {} \;

To save windows images (.png) : Alt-Print

Our client computers use the "supported" CentOS 6,
but the server is CentOS 7 (not yet supported to run Cadence)



PIP: poly1-poly2-capacitor

VG5: 5V-Gates

HRES: High resistive poly

4 Metal Layers (MET4 normal thickness)

Basic elements, available in this technology

Show additional elements for ESD

ElectroStatic Discharge

AMS-HitKit - Start

Opto

First start !
Later use "ams_cds" simply!
(or "ams_cds &" to release the terminal for further use)

Do not use your homedir!
Create a separate project directory!

= Starting Cadence Design Framework with Libraries, Rules, Scripts provided for AMS-technology
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Make your favourite directory structure
~/ske
~/ske/inverter

You may use one single directory for different designs.
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AMS-HitKit - Start

Window open for some seconds after ams_cds startWould stay open as long as ams_cds is running

Command Interpreter Window  - CIW 

Command Inputs

Messages



AMS-HitKit - A new library

File -> New -> Library

Choose a name for your library!
(You may use one library for different designs.) 

We use the 4 metal layer technology here.
Do not press OK before you have selected the TECH-library!

Quit with OK!
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Command Interpreter Window  - CIW 

2016/17

Select 
"Attach to an existing technology library" -> OK

important step!



AMS-HitKit - A new cellview

File -> New -> Cellview

Choose a cell name, check "schematic" as cellview -> OK Quit with OK !

Depends on your project path
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Your new library

Start with schematic view

Command Interpreter Window CIW



Normally the background is black, you may (but you should not for normal work) 
change to white by modifying an entry in your ~/Xdefaults file:
!Opus.editorBackground:  #000000   - >  Opus.editorBackground:         #ffffff

For printing it is sometimes interesting to have a 
white background but not all the design colours 
match white background.

When you have some content it is possible 
to create images with white background
using "File -> Export Image". There opens a form where you can
change the background colour.  Try it!

AMS-HitKit Schematic Editor is open
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Try to have a fixed arrangement for open windows (Terminal, CIW ..) 



Create -> Instance
(hotkey "i")

PRIMLIB contains all the
available elements (primitives).

NMOS,PMOS : Thin oxide 7 nm (𝑉𝐺𝑆< 3.6 𝑉)
NMOSM,PMOSM: Mid oxide 15 nm (𝑉𝐺𝑆 < 5.5 𝑉)

𝑊

𝐿

Finger

compact

Substrate contact 
in layout

Instance properties 
may be changed 
in layout-process
later
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Cells

Schematic entry - Components

Open Library Browser
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using∶ 𝐾𝑃𝑁 = 3 ∙ 𝐾𝑃𝑃

𝑈𝑡ℎ𝑝

𝑈𝑡ℎ𝑛PMOS in NPO

NMOS in NPO

Both in PO

Dissolving for 𝑉𝑖𝑛𝑆𝑃:

There is the same current flowing through both
transistors.Beide. For ideal switching point is

𝑉𝑖𝑛 = 𝑉𝐺𝑆𝑛 = 𝑉𝑆𝐺𝑝 = 𝑉𝑜𝑢𝑡 = 𝑉𝐷𝑆𝑛 = 𝑉𝑆𝐷𝑝 =
𝑉𝐷𝐷

2
.  

Because of 𝑉𝐷𝑆 > 𝑉𝐺𝑆 − 𝑉𝑡ℎ both transistors
are in the pinch-off state and we can assume:

𝑉𝑖𝑛𝑆𝑃

CMOS Inverter calculation

For desired 𝑉𝑖𝑛𝑆𝑃 =
𝑉𝐷𝐷

2
we calculate the relation

𝛽𝑛

𝛽𝑝

for 𝑉𝐷𝐷 ≫ 𝑉𝑡ℎ𝑝 − 𝑉𝑡ℎ𝑛

𝑉𝑡ℎ𝑛 = 0.5V, KPN = 170
µ𝐴

𝑉2

𝑉𝑡ℎ𝑝 = 0.65V, KPP = 58
µ𝐴

𝑉2



NMOS,PMOS : Thin oxide 7 nm (𝑉𝐺𝑆< 3.6 𝑉)
NMOSM,PMOSM: Mid oxide 15 nm (𝑉𝐺𝑆 < 5.5 𝑉)

Inverter schematic

key function

i create instance

w create wire

M move

m stretch (im Layout "S" !)

c copy

q object properties

p add pin

l add wire name (label)

x check current cellview

f fit

] zoom in

[ zoom out

key function

F3 show option window

u undo

U redo

e descend & read

E descend & edit

CTRL-e return

DEL delete

vdd, gnd etc. from library "analogLib/globals"
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For ground ports use names including "gnd".
(Some scripts (ERC) need this naming convention.)

For power ports use names including "vdd" or "vcc"

File -> Check and Save  (shft-x)

Avoid crossover dots.
Warnings! May be deselected 
Check-> Rules-> Physical
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Schematic Editor: Filter

Schematic editor has a filter function for selectable objects!
Changing accidentally may prohibit selection!

Standard

create wire
toggle 
"wire selectable"



Inverter Symbol from Schematic

Standard: rectangle

One may change shapes:
outline (green), selection frame (red)
use: stretch, delete,move,create polygon
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Symbol needed to use our design in higher levels of
hierarchy.
First Example is the insertion of the design in a testbench.

Create Cellview -> From Cellview -> OK

optional



Inverter Schematic for Simulation -> Testbench

In CIW (or Library Manager):  File -> New -> Cellview

DC-value

AC-value for 
ac-simulation
(frequency response)
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Real value for C?
Answer later.
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Simulation ADE GXL  Start 

From the Schematic Editor -> Launch -> ADE GXL

ADE (G)XL usage differs from ADE L
Most tutorials use older ADE L

ADE XL creates a new view!

LDE Layout Dependent Effects
EAD Electrically Aware Design



Choose: ADE GXL  -> Create -> Test
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Simulation ADE GXL  Create Test 



11.10.2017 IGS / Uni-Rostock 16

From Schematic

automatic, linear, logarithmic

Design Variables
Simulation Outputs

Create/Edit analyses

Delete selected analyses

Plot

Run enabled analyses
Stop

Simulation ADE GXL  Create Analyses 
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From Schematic

Simulation ADE-XL/L  Choose Outputs



11.10.2017 IGS / Uni-Rostock 18

Simulation RUN (in ADE-GXL)

Run Simulation

Plot outputs

Common Errors stopping execution of simulation:
Design changed and not saved.
Unexpected/unassigned variables due to input errors
mostly for component values.
Example: Using "Meg" instaed of "M" for "Mega..  

-> Creates a variable "eg"
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Simulation ADE-L  Evaluate Results

Tools –> Calculator

Select

In Visualization&Anlaysis Window -> Marker -> Create Marker

Markers set to find the -1 gain
to determine noise margins. 

Inflexion point (max. abs. gain value)

Recommendation: Move derivation plot to new subwindow (RM-> Move to)
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Tools -> Parametric Analysis

Select "temp" (There is nothing more when you start)!
Try the other entries! Here: -40°C to 80°C in 10° steps)

Simulation Parametric Analysis – Temperature (Built in)
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Simulation Parametric Analysis – Global Variables

Start here to create a global variable

Or start here to create a global variable.
It must be exported/backannotated to appear in test.

As an example we replace the fixed width of the PMOS transistor by a parameter "Pwidth"

If there is only the testbench schematic open,
select inverter and press "E" (descend edit) to
open the inverter schematic!
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Open object parameters (q)!
Replace fixed value by parameter!

Simulation Parametric Analysis – Global Variables

Simulation results

Start here for parametric simulation!
Start from Test Editor Window runs without
parametric variation (Default values used).
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2 ∙
𝐶𝑜𝑥2
2

2 ∙
𝐶𝑜𝑥1
2

𝐶𝑜𝑥2
2

𝐶𝑜𝑥1
2

Miller-Capacitor
When will it work? -> only, 

if 𝑉𝑖𝑛> 𝑉𝑆𝑃, bzw. 𝑉𝑖𝑛>
𝑉𝐷𝐷

2

Voltage change over C:  2 ∙ 𝑉𝐷𝐷
𝐶𝑖𝑛 =

3

2
𝐶𝑜𝑥1 + 𝐶0𝑥2

𝐶𝑜𝑢𝑡 ≈ 𝐶𝑜𝑥1 + 𝐶0𝑥2

CMOS Inverter Capacitances and Delay

Reale Verhältnisse wesentlich komplizierter:
Gate Capacitances zu Drain,Source, Channel, Bulk -> 
additional 𝐶𝑂𝑣𝑒𝑟𝑙𝑎𝑝
𝐶𝑖𝑛 nonlinear: 

Originally the junction capacitance
between drain and bulk

In the range of 𝐶𝑜𝑥 if source and bulk
are interconnected

Nonlinear ~
1

𝑉

𝐶𝑜𝑢𝑡

Region 𝐶𝐺𝑩 𝐶𝐺𝑺 𝐶𝐺𝑫 𝐶𝒊𝒏

off 𝐶𝑜𝑥 0 0 𝐶𝑜𝑥 + 2 ∙ 𝐶𝑜𝑣

NPO 0 1

2
∙ 𝐶𝑜𝑥

1

2
∙ 𝐶𝑜𝑥

𝐶𝑜𝑥 + 2 ∙ 𝐶𝑜𝑣

PO 0 -> 
2

3
∙ 𝐶𝑜𝑥 -> 0 2

3
∙ 𝐶𝑜𝑥 + 2 ∙ 𝐶𝑜𝑣

𝐶𝑜𝑣

1

2
𝐶𝑜𝑥
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𝐼𝐷 =
𝛽𝑛
2

𝑉𝐷𝐷 − 𝑉𝑡ℎ𝑛
2 =

𝐾𝑃𝑁

2

𝑊

𝐿
𝑉𝐷𝐷 − 𝑉𝑡ℎ𝑛

2 =
170

2

µ𝐴

𝑉2
∙
1µ𝑚

0.35µ𝑚
∙ 3.3𝑉 − 0.5𝑉 2= 0.68 𝑚𝐴

𝑅𝑛 = 𝑅𝑝 =
𝑉𝐷𝐷

𝐼𝐷
=

3.3𝑉

0.68𝑚𝐴
= 4.85 𝑘Ω

Output resistance of FET for charge reversal

𝐶𝑖𝑛 =
3

2
𝑊 ∙ 𝐿 ∙ 𝐶′𝑜𝑥

𝐶𝑜𝑢𝑡 = 𝑊 ∙ 𝐿 ∙ 𝐶′𝑜𝑥

𝑡𝑝𝐻𝐿 = 𝑡𝑝𝐿𝐻 = 0.7 ∙ 𝑅𝑎 ∙ 𝐶𝑖𝑛𝑛 + 𝐶𝑖𝑛𝑝 + 𝐶𝑜𝑢𝑡𝑛 + 𝐶𝑜𝑢𝑡𝑝

𝑡𝑝𝐻𝐿 = 𝑡𝑝𝐿𝐻 = 0.7 ∙ 𝑅𝑎 ∙ 𝐶′𝑜𝑥 ∙
5

2
𝑊𝑛𝐿𝑛 +𝑊𝑝𝐿𝑝

𝑡𝑝𝐻𝐿 = 𝑡𝑝𝐿𝐻 = 0.7 ∙ 4.85𝑘Ω ∙ 4.5
𝑓𝐹

µ𝑚2 ∙
5

2
1 + 3.2 µ𝑚2 = 160 ps

Single transistor at 𝑉𝐷𝐷 with input voltage at 𝑉𝐷𝐷

Kapazität und Zeitkonstante -> Delay time (50%-Schwelle)

𝐶𝑖𝑛 = 4.5
𝑓𝐹

µ𝑚2
∙
3

2
1 + 3.2 µ𝑚2 = 28.35 fF

𝐶𝑜𝑢𝑡 = 4.5
𝑓𝐹

µ𝑚2
∙ 1 + 3.2 µ𝑚2= 18.9 fFnext gate

(+ wire capacitances)

CMOS Inverter Capacitances, Output Resistance and Delay
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Simulation   Transient Analysis

Replace the vdc-source by a vpulse-source. (It would be possible to use this from the scratch even for dc-simulation!)

Try another parametric simulation 
(transient) with Load Capacitance as a 
parameter!

Period

Pulse width

Rise time Fall time

Voltage2

Voltage1

Delay

t=0

How to find proper time values?
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Simulation   Transient Analysis

Oops!, looks strange …
1pF load is too much for our small gate 

Changed load to 80 fF
Compare with data sheet of 
ams standard cell next page!

falltime: 1.555ns-1.1545ns=400 ps
risetime: 2.2404ns-2.0601ns=180 ps
delay(inp rise): 1.3324ns-1.005ns=327 ps
delay(inp fall): 2.1328ns-2.015ns=118 ps

Zur Anzeige der Schnittpunkte: RM auf Markerlinie-> Intercepts -> On
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Simulation   Transient Analysis

Try another parametric simulation with
Load Capacitance as a parameter!
Compare results with a given cell from AMS!

Uups!, explain the negative value!
fall time

propagation
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Layout Start and Generate from Schematic

Replace all the global variables in the design with fixed values.  
Global variables have their scope in simulation only.
Global Variables in the testbench are not affected, because they will not be involved in the layout. 

In Schematic Editor: Launch -> Layout XL
In Layout XL: Connectivity -> Generate ->All From Source  

Generates a layout with all instances placed outside a rectangle (estimated cell boundary) 

Text is used to recognize 
ports correctly.

Fold the PMOS (2 gates)
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Point 0,0

Edit ->  Stretch
Tools->  Create Measurement*

RM -> 

Layout Floorplaning

Suggested cell area
20µm x6 µm cell

Tools -> Clear All Measurements*m
Create -> Shape -> Rectangle

+

When moving pins include all parts. 
Best practice: Snap to the little "+"!

To see all layers: Options -> Display -> Display Levels -> Set "stop" to 32        (Shift-f) Save to ~/.cdsenv

*Ruler in older versions

F3 opens move options (e.g. orthogonal, all angels etc.) 
(F3 opens options for all commands)

Don't have Bulk ?
Delete both transistors in layout.
Open schematic and change transistor property there (add substrate contact).
In Layout XL use Connectivity -> Update Components and Nets.
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actual layer

visible/selectable

Create -> Shape -> Rectangle

First corner 0:0
Opposite Corner 6:3
Input with mouse or in CIW:
0:0 enter  -> 6:3 enter

0:0

6:3

Layout Edit

Edit -> Copy 

0:17

6:20



Creating VIAs:
PD_C   :   p-Substrat-Metal1
ND_C   :   n-Well-Metal1
P1_C    :   Poly1-Metal1
P2_C    :   Poly2-Metal1
VIA1_C :   Metal1-Metal2
VIA2_C :   Metal2-Metal3
VIA3_C :   Metal3-Metal4

Layout of single contact predefined. Do not change!
Number and alignment variable. Using "Compute from
Shape(s)" fills area with appropriate number of contacts.

Stacked VIAs connecting more than
two layers available:

Layout - VIAs
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Make them for the power stripes before
routing of wires.

}



POLY1

MET1

MET1-rail for vdd!

MET1-rail for gnd!

gnd! ->  Exclamation mark: global signal

PIN in MET1

PD_C p-Substrat-Metal1 VIA

ND_C n-Well-Metal1 VIA

P1_C Poly1-Metal1 VIA

n-Well extended for vdd connection
and merging with adjacent cells

-0.5:10 -> 6.5:20.5
Remember usage in (flipped) raws

Cell Layout

Hight: 20 µm, Width: 6µm

Cell hight of ams digital standard cells 13 µm
Simple Inverter 30 µ𝑚2

To consider (design rules):
Poly1: width ≥ 0.35µ, space ≥ 0.45µ
Metal1: width ≥ 0.5µ, space ≥ 0.45µ
Metal2: width ≥ 0.6µ, space ≥ 0.5µ
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pmos-Transistor
in n-well (folded)

must enclose vdd!-pin

must enclose gnd!-pin

nmos-Transistor

Transistors n-Well
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Cadence  Layout - LVS

Compare Layout Versus Schematic

Assura ->  Run LVS

Necessary for QRC parasitic extraction
That's what we want to see!

wait!
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Cadence  Layout - DRC

Assura -> Run DRC

Set these switches to avoid
some messages (see below!).
What does "Coverage" mean?

Here you may open the 
rule set file for information.
Contains all the rules like
distances, overlap, min. width
et cetera.

That's what we would like to see!
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Cadence  Layout – DRC  with Errors remaining

View -> Error Report

Browse Errors (if multiple)

Example for an Error Message:
Here: Pin is not fully covered by metal

Position in Layout

Position in Layout

Violated Rule

Violated Rule

Solutions:
Extend wire to the right or
add a rectangle in MET1 covering the Pin
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Cadence  Layout - DFM

Assura -> Run DRC

Errors because we did not use 
some layers.
Interesting for a top layout.

Extended ruleset:
Rules for manufacturing ->

Coverage of all but upper metal 
layer et cetera.

no switches!
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Cadence  Layout - ERC

Electrical rule check is included in DRC.
There is no separate rule check in the ams-HITkit.

Starting ERC with Assura -> Run ERC opens a form similar to DRC
with no technology selected and either rule files.

Up to now no verification for this.
Separate ERC-usage found nowhere.
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Cadence  Layout – QRC – Parametric Extraction

Coupled C:  net to net (signals)
Decoupled C: net to power and ground only 

use gnd! or vcc!

no changes
RC

QRC -> Run Assura Quantus -QRC

wait!
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Cadence – QRC – Extracted view

pico 10−12

femto 10−15

atto 10−18

zepto 10−21

Launch -> Plugins ->Parasitics : New Tab "Parasitics"
Parasitics -> Setup Parasitics (gnd! and vdd! as reference nodes)

In Schematic or av_extracted view:
Launch -> Parasitics : New Tab "Parasitics"
Parasitics -> Report Parasitics -> net : Select with cursor
In Schematic Parasitics -> Show Parasitics :  Lumped values

Viewing parasitics may be interesting.
More important is their use in postlayout simulation.
They will be included in simulation netlists.

Zoom

Try also: net to net
terminal to terminal (r)

Open View "av_extracted" in Library Manager
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Cadence – QRC – Post-Layout Simulation (ADE-L/XL)

Open testbench (schematic)
Copy the inverter and its load.
Save as a new testbench.

We need different models for the UUT (inverter)
• Original schematic
• Netlist with extracted parasitics.In CIW:

File -> New -> Cellview

In Schematic Editor:

Launch -> Hierachy Editor

In new Tab "Hierarchy-Editor"

Edit Configuration

Begin here!
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Cadence – Post-Layout Simulation (ADE-L/XL)

41

Parasitics

Replace (use RightMouse -> set instance view ) schematic by av_extracted
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Cadence – Post-Layout Simulation - Result

OK, delay increased by some ps
OK, no visible change

Shown for 𝐶𝐿𝑜𝑎𝑑= 4 fF. Less difference for higher load. 

20%

50%

80%

40ps

30ps

To perform simulation see slides above 
from "Simulation ADE GXL  Start"  

Open the configuration in Library Manager
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Layout 3D View

GDS3D from University of Twente, NL

Needs a technology file (layer thickness, pitches). Generated for AMSC35B4 from process parameters.
Needs initialization for Cadence integration, but may be used standalone. 

Automatic initialization does not work yet. For manual initialization observe the last output
after CIW start.

With a layout opened we can make a GDSII-Stream and
run the GDS3D tool.  ICD - Tools

In the GDS3D-tool use F1 to see the (game like) usage.

Do not use the normal streamout from CDW (File -> Export -> Stream) because GDS3D
uses a separate directory for the gds-File!

ICD is simply Integrated Circuit Design group
at Twente University)
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Layout 3D View

MET1 display deselected.
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Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
Inverter,  2-Input-NAND,  2-Input-NOR

𝑈𝐵 = 3,3𝑉
𝑈𝐺𝑆0𝑛 = 0,48V
𝑈𝑆𝐺0𝑝 = 0,67𝑉

𝐾𝑃𝑛 = 170
µ𝐴

𝑉2

𝐾𝑃𝑝 = 58
µ𝐴

𝑉2

(𝑑𝑜𝑥 = 7,6 𝑛𝑚)
Calculate the geometry in ( Τ𝑊 𝐿-ratio for p- und n-Transistors) so that you get a good compromise for the switching point
and noise margin for the cases:
- Both inputs change at the same moment (connected)
- One input is preassigned to a fixed value so that the second one causes output change. (May be different for both inputs!)

Switching point should be near
𝑈𝐵

2
for all cases.

Design (schematic, layout) a 2-Input-NAND or a 2-Input-NOR  using short channel length transistors (0.35µ) 
or long channel length transistors (3.5µm]. Selection of the specific design is done with the tutor. 

Cell hight shall be 20 µm.

From Simulation (including postlayout) find out the following values: 
Switching points and noise margin for the different cases at the two inputs.
Delay times (50%), falltime, risetime (20%-80%) dependend on load capacitance (4.. 100 fF) and temperature (-40 to 80°C).
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𝛽𝑛
2

𝑈𝑒𝑆 − 𝑈𝐺𝑆0𝑛
2 =

𝛽𝑝
2

𝑈𝐵 − 𝑈𝑒𝑆 − 𝑈𝑆𝐺0𝑝
2

𝛽𝑛 𝑈𝑒𝑆 − 𝑈𝐺𝑆0𝑛 = 𝛽𝑝 𝑈𝐵 − 𝑈𝑒𝑆 − 𝑈𝑆𝐺0𝑝

𝑈𝑒𝑆 =

𝛽𝑛
𝛽𝑝

∙ 𝑈𝐺𝑆0𝑛 + 𝑈𝐵 − 𝑈𝑆𝐺0𝑝

1 +
𝛽𝑛
𝛽𝑝

𝛽𝑛
𝛽𝑝

=

𝑈𝐵
2
− 𝑈𝑆𝐺0𝑝

𝑈𝐵
2
− 𝑈𝐺𝑆0𝑛

2

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙

𝑈𝐵
2
− 𝑈𝑆𝐺0𝑝

𝑈𝐵
2
− 𝑈𝐺𝑆0𝑛

2

𝛽 = 𝐾𝑃 ∙
𝑊

𝐿
𝑚𝑖𝑡 ∶ 𝐾𝑃𝑁 = 3 ∙ KPP

Für 𝑈𝑒𝑆 =
𝑈𝐵

2

𝑈𝑆𝐺0𝑝

𝑈𝐺𝑆0𝑛
PMOS im NPO

NMOS im NPO

Beide im PO

Dissolve for 𝑈𝑒𝑆:

At the switching point both transistor-pairs are in the pinch-off state and passed
by the same current :  

𝛽𝑛
2

𝑈𝑒𝑆 − 𝑈𝐺𝑆0𝑛
2 =

𝛽𝑝

2
𝑈𝐵 − 𝑈𝑒𝑆 − 𝑈𝑆𝐺0𝑝

2

But: There is a difference in the number of involved switching transistors
for the different input cases!

Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
Inverter,  2-Input-NAND,  2-Input-NOR

Common Equation for CMOS-Inverter:
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Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
Inverter,  2-Input-NAND,  2-Input-NOR

NAND-Gate

𝛽𝑛𝑔𝑒𝑠

𝛽𝑝𝑔𝑒𝑠
=

𝑈𝐵
2
− 𝑈𝑆𝐺0𝑝

𝑈𝐵
2
− 𝑈𝐺𝑆0𝑛

2

𝑊
𝐿 𝑛

𝑊
𝐿 𝑝

=
4

3
∙

𝑈𝐵
2
− 𝑈𝑆𝐺0𝑝

𝑈𝐵
2
− 𝑈𝐺𝑆0𝑛

2

𝛽𝑛𝑔𝑒𝑠 = 𝐾𝑃𝑁 ∙
1

2

𝑊

𝐿
𝑛

𝛽𝑝𝑔𝑒𝑠 = 𝐾𝑃𝑃 ∙ 2
𝑊

𝐿
𝑝

𝐾𝑃𝑁 = 3 ∙ KPP

For 𝑈𝑒𝑆 =
𝑈𝐵

2
when both inputs change:

𝑊
𝐿 𝑛

𝑊
𝐿 𝑝

=
4

3
∙

𝑈𝐵
2
− 𝑈𝑆𝐺0𝑝

𝑈𝐵
2
− 𝑈𝐺𝑆0𝑛

2

=
4

3

1,65 − 0,7

1,65 − 0,5

2

= 0,908

One transistor of double length

One transistor of double width

𝑊
𝐿

𝑝

𝑊
𝐿

𝑛

= 1,1
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𝛽𝑛
2

𝑈𝑒𝑆 − 𝑈𝐺𝑆0𝑛
2 =

𝛽𝑝
2

𝑈𝐵 − 𝑈𝑒𝑆 − 𝑈𝑆𝐺0𝑝
2

𝛽𝑛 𝑈𝑒𝑆 − 𝑈𝐺𝑆0𝑛 = 𝛽𝑝 𝑈𝐵 − 𝑈𝑒𝑆 − 𝑈𝑆𝐺0𝑝

𝑈𝑒𝑆 =

𝛽𝑛
𝛽𝑝

∙ 𝑈𝐺𝑆𝑂𝑛 + 𝑈𝐷𝑆11 + 𝑈𝐵 − 𝑈𝑆𝐺0𝑝

1 +
𝛽𝑛
𝛽𝑝

𝛽𝑛
𝛽𝑝

=

𝑈𝐵
2
− 𝑈𝑆𝐺0𝑝

𝑈𝐵
2
− 𝑈𝐺𝑆0𝑛 − 𝑈𝐷𝑆11

2

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙

𝑈𝐵
2
− 𝑈𝑆𝐺0𝑝

𝑈𝐵
2
− 𝑈𝐺𝑆0𝑛 − 𝑈𝐷𝑆11

2

Für 𝑈𝑒𝑆 =
𝑈𝐵

2

Lower transistor in NAND during switching phase:

𝛽𝑛𝑔𝑒𝑠 = 𝐾𝑃𝑁 ∙
𝑊

𝐿

𝛽𝑝𝑔𝑒𝑠 = 𝐾𝑃𝑁 ∙
𝑊

𝐿
𝐾𝑃𝑁 = 3 ∙ KPP

One p-transistor is and remains off.
One n-Transistor is and remains on.
Only an inverter is switching.

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙

1,65 − 0,7

1,65 − 0,5 − 0,236𝑉

2

= 0.36

𝑊
𝐿

𝑝

𝑊
𝐿

𝑛

= 2,78

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙
1,65 − 0,7

1,65 − 0,5

2

= 0,23

𝑊
𝐿

𝑝

𝑊
𝐿

𝑛

= 4,44

Interesting, but we can implement one geometry only
and must configure a compromise. 

See if the values are acceptable with regard to noise margin.
Try to change W/L ratios to find a compromise.

Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
Inverter,  2-Input-NAND,  2-Input-NOR
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Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
Inverter,  2-Input-NAND,  2-Input-NOR

Starting from the Inverter schematic:

You may open the inverter schematic as the origin for the new design.

Then create a new schematic cellview (from CDW or Library Manager).  File -> New -> Cellview

When you have the new empty schematic and the inverter schematic side by side you can copy the
inverter circuit or parts of it to the new schematic.

Use copy: "c" -> select the desired part using the left mouse button 
-> click on the selected part 
-> drag to the new place (may be the same schematic window or the new one)

Edit the new schematic to build the NAND or NOR design.

Practical hint to safe time:

You may proceed in the same manner for the testbench.
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2-input-NAND
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From Schematic

automatic, linear, logarithmic

Design Variables
Simulation Outputs

Create/Edit analyses

Delete selected analyses

Plot

Run enabled analyses
Stop
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From Schematic

Intranet

https://www.igs.uni-rostock.de/intranet/
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Transfer characteristics and noise margin for 2-Input-CMOS-NAND-Gate 

𝑑𝑉𝑜𝑢𝑡
𝑑𝑉𝑖𝑛
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Transfer characteristic of 2-input-NAND-Gates from AMS-0.35µ-library
with 𝐿𝑁𝑀𝑂𝑆,𝑃𝑀𝑂𝑆 = 0.35µ 𝑊𝑁𝑀𝑂𝑆 = 1.325µ,𝑊𝑃𝑀𝑂𝑆 = 2.1µ and self-made  gate

with 𝐿𝑁𝑀𝑂𝑆,𝑃𝑀𝑂𝑆 = 0.35µ 𝑊𝑁𝑀𝑂𝑆 = 1.0µ,𝑊𝑃𝑀𝑂𝑆 = 1.6µ
(Characteristic for top N-transistor not shown, always beetween bottom and both)

Transfer characteristic for 2-Input-CMOS-NAND-Gates
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Simulation of 4-input-NAND from 0.35µm library

D-input uses NMOS-transistor nearest to GND, A-
input is top NMOS-transistor. 



11.10.2017 IGS / Uni-Rostock 56

Transfer characteristic of 4-input-NAND-Gate from AMS-0.35µ-library
with 𝐿𝑁𝑀𝑂𝑆,𝑃𝑀𝑂𝑆 = 0.35µ 𝑊𝑁𝑀𝑂𝑆 = 1.05µ,𝑊𝑃𝑀𝑂𝑆 = 1.4µ
Leftmost line for switching lowest (nearest to ground )nmos-transistor only, 
rightmost line for all 4 inputs switched simultaneously

o_d

o_abcd

4-Input-NAND-Gate


