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Tutorial for creation of an inverter cell from schematic to layout with CADENCE 
using AMS-Hitkit and hints for multi-input gates

1. Using the Linux (CentOS) environment
2. Starting CADENCE with AMS-Hitkit
3. Creating a new library
4. Schematic entry 
5. Creating a symbol and a testbench
6. Spice-Simulation using ADE XL

• Analyses selection and setup
• Using global variables
• Parametric simulation

7. Starting Layout XL
• Generate layout from schematic
• The layer window
• Wires, vias/contacts, wells

8. Design rule check
9. Layout versus schematic check (LVS)
10. Parasitic extraction (QRC)
11. Simulation of the extracted model (Post-layout simulation)

Cadence + AMS-Hitkit
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Some UNIX-commands

pwd print working directory
ls,  ls –alsi, ls dir list
cd  ->  cd /~/ske ->  cd  ./ske change directory
mkdir newdir make directory
cp , cp -r, cp -p copy files/directories (recursive, preserve attributes)
mv move or rename directories
chmod,  chmod –R   chmod 744 file change file mode bits (security) -> -R recursive
grep filter for pattern
use of | for pipeline  ->   ls | grep pattern use command output as input for next command
rm, rm –r remove/delete
rmdir remove directory
cat  file show file at standard output
man cmd show manual of cmd

We use CentOS-Linux (Free version "Community Enterprise OS" of RedHat), because Cadence supports RedHat or Suse.
We use the KornShell (ksh), because it is the standard shell at ITMZ Uni Rostock.

Or Right-Mouse on Background and select "Open Terminal"

Move icon to desktop for easy use

Unix-command to remove Cadence lock files (Close all Cadence programs before!) : find ~/  -name  "*.cdslck" -exec  rm {} \;

To save windows images (.png) : Alt-Print

Our client computers use the "supported" CentOS 7,
binary compatible to RedHat 7.5

history, h    show command history
r 100             run command number 100 from history



PIP: poly1-poly2-capacitor

VG5: 5V-Gates

HRES: High resistive poly

4 Metal Layers (MET4 normal thickness)

Basic elements, available in this technology

Show additional elements for ESD

ElectroStatic Discharge

AMS-HitKit - Start

Opto

First start !
Later use "ams_cds" simply!
(or "ams_cds &" to release the terminal for further use)

Do not use your homedir!
Create a separate project directory!

= Starting Cadence Design Framework with Libraries, Rules, Scripts provided for AMS-technology
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Make your favourite directory structure
~/ske
~/ske/inverter

You may use one single directory for different designs.



17.12.2018 IGS / Uni-Rostock 4

AMS-HitKit - Start

Windows open for some seconds after ams_cds start
Would stay open as long as ams_cds is running

Command Interpreter Window  - CIW 

Command Inputs

Messages



AMS-HitKit - A new library

File -> New -> Library

Choose a name for your library!
(You may use one library for different designs.) 

We use the 4 metal layer technology here.
Do not press OK before you have selected the TECH-library!

Quit with OK!
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Command Interpreter Window  - CIW 

Select 
"Attach to an existing technology library" -> OK

important step!
If we skip this step, we will not
see any elements for layout
later

It is possible to create the library using the LIbrary Manager instead of CIW as well. The flow will differ (windows sequence).



AMS-HitKit - A new cellview

File -> New -> Cellview

Choose a cell name, check "schematic" as cellview -> OK Quit with OK !

Depends on your project path
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Your new library

Start with schematic view

Command Interpreter Window CIW       (You can do this in the Library Manager as well)

Best choice for names/identifiers: use letters, numbers, underscore only



Normally the background is black, you may (but you should not for normal work) 
change to white by modifying an entry in your ~/Xdefaults file:
!Opus.editorBackground:  #000000   - >  Opus.editorBackground:         #ffffff

For printing it is sometimes interesting to have a 
white background but not all the design colours 
match white background.

When you have some content it is possible 
to create images with white background
using "File -> Export Image". There opens a form where you can
change the background colour.  Try it!

AMS-HitKit Schematic Editor is open
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Try to have a fixed arrangement for open windows (Terminal, CIW ..) 



Create -> Instance
(hotkey "i")

PRIMLIB contains all the
available elements (primitives).

NMOS,PMOS : Thin oxide 7 nm (𝑉𝐺𝑆< 3.6 𝑉)
NMOSM,PMOSM: Mid oxide 15 nm (𝑉𝐺𝑆 < 5.5 𝑉)

𝑊

𝐿

Finger

compact

Substrate contact 
in layout (not used here)

Instance properties 
may be changed 
in layout-process
later
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Cells

Schematic entry - Components

Open Library Browser

Guard rings sorrounding
trnsistors in analog circuits
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𝑉𝑓𝑏 = 𝑉𝐺 − 𝑉𝑂𝑋 + 𝑉𝑂𝑋 − 𝑉𝑓𝑝 = 𝑉𝐺 −𝑉𝑓𝑝 =
𝑘𝑇

𝑒
𝑙𝑛
𝑁𝐷𝑝𝑜𝑙𝑦

𝑛𝑖
+
𝑘𝑇

𝑒
𝑙𝑛
𝑁𝐴𝑆𝑢𝑏𝑠𝑡𝑟

𝑛𝑖
=
𝑘𝑇

𝑒
𝑙𝑛
𝑁𝐷𝑝𝑜𝑙𝑦 ∙ 𝑁𝐴𝑆𝑢𝑏𝑠𝑡𝑟

𝑛𝑖

contact voltage(s))
𝑉𝑇𝐻 =

𝑄𝑏
′−𝑄𝑆𝑆

′

𝐶𝑂𝑋
′ − 2𝑉𝑓𝑝 - 𝑉𝑐𝑜𝑛𝑡𝑎𝑐𝑡

inversion voltage

MOSFET: Threshold Voltage

Voltage necessary to achieve channel inversion

2x the potential in the depletion area

(from p-conduction to zero to n-conduction)

−𝑉𝑆𝐵

Φ𝐹 𝑔𝑎𝑡𝑒= 
𝑘𝑇

𝑒
𝑙𝑛

𝑁𝐷𝑝𝑜𝑙𝑦

𝑛𝑖
Remember that the gate is

used as the mask for the

doping process making source and drain

(self alignment)

Φ𝐹 𝑠𝑢𝑏𝑠𝑡𝑟 = 𝑉𝑓𝑝 = −
𝑘𝑇

𝑒
𝑙𝑛

𝑁𝐴𝑠𝑢𝑏𝑠𝑡𝑟

𝑛𝑖

flatband voltage

narrow depletion in heavely doped gate

effective gate thickness increases

Al𝑛+ Poly-Si

𝑉𝐷𝑆 (GND)𝐺𝑁𝐷

p-Substrate

𝑉𝐺(𝑆)

Al

𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+ 𝑡𝑑

Voltage over gate oxide (observe that the charge quantity on gate is equal to bulk  𝑄𝑔 = −𝑄𝑏)
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contact voltage(s)

𝑉𝑇𝐻 =
𝑄𝑏
′−𝑄𝑆𝑆

′

𝐶𝑂𝑋
′ − 2𝑉𝑓𝑏 - 𝑉𝑐

inversion voltage

voltage over gate oxide

𝑄𝑏
′ − 𝑄𝑆𝑆

′

𝐶𝑂𝑋
′ =

𝑄𝑏0
′ − 𝑄𝑆𝑆

′

𝐶𝑂𝑋
′ −

𝑄𝑏0
′ − 𝑄𝑏

′

𝐶𝑂𝑋
′

𝑄𝑏0
′ = 𝑒𝑁𝐴𝑡𝑑 = 𝑒𝑁𝐴

2𝜀𝑆𝑖 ∙ 𝑉𝐺 − 𝑣𝑓𝑏

𝑒 ∙ 𝑁𝐴
= 2𝑒𝑁𝐴𝜀𝑆𝑖 ∙ −2 𝑣𝑓𝑏

𝑡𝑑 =
2𝜀𝑆𝑖 𝑉𝐺 − 𝑣𝑓𝑏

𝑒 ∙ 𝑁𝐴

𝑄𝑏
′ = 𝑒𝑁𝐴𝐷𝑑 = 𝑒𝑁𝐴

2𝜀𝑆𝑖 ∙ 𝑉𝑆 − 𝑣𝑓𝑏

𝑒 ∙ 𝑁𝐴
= 2𝑒𝑁𝐴𝜀𝑆𝑖 ∙ −2𝑣𝑖 + 𝑉𝑆𝐵

without bulk voltage

with bulk voltage

charge on gate = - charge on substrate

𝑉𝑇𝐻 = −2𝑉𝑓𝑏 - 𝑉𝑐 +
𝑄𝑏0
′ −𝑄𝑆𝑆

′

𝐶𝑂𝑋
′ −

𝑄𝑏0
′ −𝑄𝑏

′

𝐶𝑂𝑋
′ = −2𝑉𝑓𝑏 − 𝑉𝑐 +

𝑄𝑏0
′ −𝑄𝑆𝑆

′

𝐶𝑂𝑋
′ +

2𝑒𝑁𝐴𝜀𝑆𝑖

𝐶𝑂𝑋
′ −2𝑣𝑓𝑏 + 𝑉𝑆𝐵 − −2𝑣𝑓𝑏

MOSFET: Threshold Voltage

Compare with pn-junction, but here one side

weakly doped: 𝑢𝑖 < 2 ∙ 300𝑚𝑉

Thickness of depletion

area -> pn junction

𝑉𝐺 = −𝑣𝑓𝑏

Charge per area in

channel volume element

made to define a fixed part and a 𝑉𝑆𝐵-dependent part



𝑉𝑇𝐻 = −2𝑣𝑓𝑏 − 𝑉𝑐 +
𝑄𝑏0
′ −𝑄𝑆𝑆

′

𝐶𝑂𝑋
′ +

2𝑒𝑁𝐴𝜀𝑆𝑖

𝐶𝑂𝑋
′ −2𝑣𝑓𝑝 + 𝑉𝑆𝐵 − −2𝑣𝑓𝑝

𝑉𝑇𝐻 = −2𝑉𝑓𝑝− 𝑉𝑐 −
𝑄𝑆𝑆
′

𝐶𝑂𝑋
′ +

𝑄𝑏0
′

𝐶𝑂𝑋
′ + 𝛾 −2𝑣𝑓𝑝 + 𝑉𝑆𝐵 − −2𝑣𝑓𝑝

𝑉𝑇𝐻 = − 𝑉𝑐 −
𝑄𝑆𝑆
′

𝐶𝑂𝑋
′ − 2𝑣𝑓𝑏 +

𝑄𝑏0
′

𝐶𝑂𝑋
′ + 𝛾 −2𝑣𝑓𝑝 + 𝑉𝑆𝐵 − −2𝑣𝑓𝑝

𝑉𝑇𝐻 = 𝑉𝐹𝐵 − 2𝑣𝑓𝑝 +
𝑄𝑏0
′

𝐶𝑂𝑋
′ + 𝛾 −2𝑣 𝑓𝑝 + 𝑉𝑆𝐵 − −2𝑣𝑓𝑝

2𝑒𝑁𝐴𝜀𝑆𝑖 ∙ −2 𝑣𝑓𝑝

𝑉𝑇𝐻 = 𝑉𝐺𝑆0 = 𝑉𝑇𝐻0 + 𝛾 −2𝑣𝑓𝑝 + 𝑉𝑆𝐵 − −2𝑣𝑓𝑝

𝛾 – body effect parameterr

MOSFET: Threshold Voltage

𝑉𝐹𝐵- Flat Band Voltage

𝑉𝑇𝐻 depends on:

substrate doping 𝑄𝑏0
′ (used for adjustment)

steep retrograde doping (light at surface, strong in body)

thin channel, less dependent on 𝑉𝑆𝐵)

oxide thickness (some nm, 2..20)

substrate voltage (consider transistor location

in circuit relative to GND/VCC)

gate material (metal, n+-Si, p+-Si)

surface charge density 𝑄𝑆𝑆
′ (Si, Na – ions)

−2𝑣𝑓𝑝

surface potential

𝑄𝑏0
′ − charge per top area under

gate oxide in length ∆𝐿

𝑄𝑆𝑆
′ −charge stacked at surface

contact voltage

does not depend on 𝑉𝑆𝐵
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𝑄′ 𝑦 = 𝐶𝑂𝑋
′ (𝑉𝐺𝑆 − 𝑉 𝑦 − 𝑉𝑡ℎ)

𝑑𝑅 =
1

µ𝑛𝑄
′ 𝑦

∙
𝑑𝑦

𝑊
𝑟□

𝑑𝑉 𝑦 = 𝐼𝐷 ∙ 𝑑𝑅 =
𝐼𝐷

𝑊 ∙ µ𝑛𝑄
′ 𝑦

∙ 𝑑𝑦

𝐼𝐷 ∙ 𝑑𝑦 = 𝑊 ∙ µ𝑛 ∙ 𝐶𝑂𝑋
′ (𝑉𝐺𝑆 − 𝑉 𝑦 − 𝑉𝑡ℎ)𝑑𝑉 𝑦

µ𝑛 ∙ 𝐶𝑂𝑋
′ = µ𝑛 ∙

𝜀𝑂𝑋
𝑡𝑂𝑋

= 𝐾𝑃𝑛

𝐼𝐷 ∙ 𝑑𝑦 = 𝑊 ∙ 𝐾𝑃𝑛 ∙ (𝑉𝐺𝑆 − 𝑉 𝑦 − 𝑉𝑡ℎ)𝑑𝑉 𝑦

MOSFET: Control Equation

Charge of gate capacitor per area ∆𝑦 ∙ 𝑊

𝜌 =
1

𝑒 ∙ 𝑛 ∙ 𝜇
=

1

𝑄′ 𝑦
𝑡𝑐

∙ 𝜇

𝑟□ =
𝜌

𝑡𝑐
=

1

𝜇 ∙ 𝑄′ 𝑦

𝑑𝑦

𝑡𝑂𝑋, 𝜀𝑂𝑋
Gate

𝑡𝑐

𝐼𝐷

Charge in volume ∆𝑦 ∙ 𝑊 ∙ 𝑡𝑐

Effective mobility in inverted channel less 

than mobility in table for n-Si : 450 vs. 1650 
𝑐𝑚2

𝑉𝑠

L

AlPoly-Si

𝑉𝐷𝑆𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al
𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+

0 y , y+dy

We do not know the profile of the channel in advance
but we can evaluate the conditions in a small volume
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𝐼𝐷 ∙ 𝑑𝑦 = 𝑊 ∙ 𝐾𝑃𝑛 ∙ (𝑉𝐺𝑆 − 𝑉 𝑦 − 𝑉𝑡ℎ) ∙ 𝑑𝑉 𝑦

𝐼𝐷න

0

𝐿

𝑑𝑦 =𝑊 ∙ 𝐾𝑃𝑛 න

0

𝑉𝐷𝑆

(𝑉𝐺𝑆 − 𝑉𝑡ℎ − 𝑉 𝑦 ) ∙ 𝑑𝑉 𝑦

𝐼𝐷 =
𝑊

𝐿
∙ 𝐾𝑃𝑛 ∙ 𝑉𝐺𝑆 − 𝑉𝑡ℎ 𝑉𝐷𝑆 −

𝑉𝐷𝑆
2

2
= β ∙ 𝑉𝐺𝑆 − 𝑉𝑡ℎ 𝑉𝐷𝑆 −

𝑉𝐷𝑆
2

2

MOSFET: Control Equation, non pinched off

AlPoly-Si

𝑉𝐷𝑆𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al
𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+
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𝐼𝐷 =
𝑊

𝐿
∙ 𝐾𝑃𝑛 ∙ 𝑉𝐺𝑆 − 𝑉𝑡ℎ 𝑉𝐷𝑆 −

𝑉𝐷𝑆
2

2

𝑉𝐺𝑆 − 𝑉𝑡ℎ ≤ 𝑉𝐷𝑆Pinch off when:

𝐼𝐷 =
𝑊

𝐿
∙ 𝐾𝑃𝑛 ∙

𝑉𝐺𝑆 − 𝑉𝑡ℎ
2

2
=
𝛽

2
∙ 𝑉𝐺𝑆 − 𝑉𝑡ℎ

2

MOSFET: Control Equation, pinched off

AlPoly-Si

𝑉𝐷𝑆𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al
𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+

AlPoly-Si

𝑉𝐷𝑆𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al
𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+
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𝐼𝐷 =
𝑊

𝐿
∙ 𝐾𝑃𝑛 ∙

𝑉𝐺𝑆 − 𝑉𝑡ℎ
2

2
=
𝛽

2
∙ 𝑉𝐺𝑆 − 𝑉𝑡ℎ

2

𝐼𝐷 =
𝛽

2
∙ 𝑉𝐺𝑆 − 𝑉𝑡ℎ

2 →
𝛽

2
∙ 𝑉𝐺𝑆 − 𝑉𝑡ℎ

2 ∙ 1 + λ ∙ 𝑉𝐷𝑆 − 𝑉𝐷𝑆𝑠𝑎𝑡

Channel-length modulation

MOSFET: Control Equation, pinched off

AlPoly-Si

𝑉𝐷𝑆𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al
𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+

𝐿′ 𝐿

Charge carriers moved by
electric field through substrate

0
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𝛽𝑛
2

𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑛
2 =

𝛽𝑝
2

𝑉𝐷𝐷 − 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑝
2

𝛽𝑛 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑛 = 𝛽𝑝 𝑉𝐷𝐷 − 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑝

𝑉𝑖𝑛𝑆𝑃 =

𝛽𝑛
𝛽𝑝

∙ 𝑉𝑡ℎ𝑛 + 𝑉𝐷𝐷 − 𝑉𝑡ℎ𝑝

1 +
𝛽𝑛
𝛽𝑝

𝛽𝑛
𝛽𝑝

=

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑉𝐷𝐷
2

− 𝑈𝑡ℎ𝑛

2

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑛

2

≈
1

3

𝛽 = 𝐾𝑃 ∙
𝑊

𝐿
using∶ 𝐾𝑃𝑁 = 3 ∙ 𝐾𝑃𝑃

𝑉𝑡ℎ𝑝

𝑉𝑡ℎ𝑛PMOS in NPO

NMOS in NPO

Both in PO

Dissolving for 𝑉𝑖𝑛𝑆𝑃:

There is the same current flowing through both
transistors.Beide. For ideal switching point is

𝑉𝑖𝑛 = 𝑉𝐺𝑆𝑛 = 𝑉𝑆𝐺𝑝 = 𝑉𝑜𝑢𝑡 = 𝑉𝐷𝑆𝑛 = 𝑉𝑆𝐷𝑝 =
𝑉𝐷𝐷

2
.  

Because of 𝑉𝐷𝑆 > 𝑉𝐺𝑆 − 𝑉𝑡ℎ both transistors
are in the pinch-off state and we can assume:

𝑉𝑖𝑛𝑆𝑃

CMOS Inverter Calculation

For desired 𝑉𝑖𝑛𝑆𝑃 =
𝑉𝐷𝐷

2
we calculate the relation

𝛽𝑛

𝛽𝑝

for 𝑉𝐷𝐷 ≫ 𝑉𝑡ℎ𝑝 − 𝑉𝑡ℎ𝑛

𝑉𝑡ℎ𝑛 = 0.5V, KPN = 170
µ𝐴

𝑉2

𝑉𝑡ℎ𝑝 = 0.65V, KPP = 58
µ𝐴

𝑉2



NMOS,PMOS : Thin oxide 7 nm (𝑉𝐺𝑆< 3.6 𝑉)
NMOSM,PMOSM: Mid oxide 15 nm (𝑉𝐺𝑆 < 5.5 𝑉)

Inverter schematic

key function

i create instance

w create wire

M move

m stretch (im Layout "S" !)

c copy

q object properties

p add pin

l add wire name (label)

x check current cellview

f fit

] zoom in

[ zoom out

key function

F3 show option window

u undo

U redo

e descend & read

E descend & edit

CTRL-e return

DEL delete

vdd, gnd etc. from library "analogLib/globals"
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For ground ports use names including "gnd".
(Some scripts (ERC) need this naming convention.)

For power ports use names including "vdd" or "vcc"

File -> Check and Save  (shft-x)

Avoid crossover dots.
Warnings! May be deselected 
Check-> Rules-> Physical

tranistors from library "PRIMLIB"
(also Design-R,C,L)   

no substrate contact for
the transistors in logic

Form: name,
direction ..
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Schematic Editor: Filter

Schematic editor has a filter function for selectable objects!
Changing accidentally may prohibit selection!

Standard

create wire
toggle 
"wire selectable"



Inverter Symbol from Schematic

Standard: rectangle

One may change shapes:
outline (green), selection frame (red)
use: stretch, delete,move,create polygon
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Symbol needed to use our design in higher levels of
hierarchy.
First Example is the insertion of the design in a testbench.

Create Cellview -> From Cellview -> OK

optional



Inverter Schematic for Simulation -> Testbench

In CIW (or Library Manager):  File -> New -> Cellview

DC-value

AC-value for 
ac-simulation
(frequency response)
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Real value for C?
Answer later.

Her we use R,L,C from analogLib because we use them
for simulation environment only, not for our design

RM-> add name -> "in"

RM-> add name -> "out"
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Simulation ADE GXL  Start 

From the Schematic Editor -> Launch -> ADE GXL

ADE (G)XL usage differs from ADE L
Most tutorials use older ADE L

ADE XL creates a new view!

LDE Layout Dependent Effects
EAD Electrically Aware Design



Choose: ADE GXL  -> Create -> Test
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Simulation ADE GXL  Create Test 
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From Schematic

automatic, linear, logarithmic

Global or Design Variables
Simulation Outputs

Create/Edit analyses

Delete selected analyses

Plot

Run enabled analyses
Stop

Simulation ADE GXL  Create Analyses 
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From Schematic

Simulation ADE-XL/L  Choose Outputs
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Simulation RUN (in ADE-GXL)

Run Simulation

Plot outputs

Common Errors stopping execution of simulation:
Design changed and not saved.
Unexpected/unassigned variables due to input errors
mostly for component values.
Example: Using "Meg" instaed of "M" for "Mega..  

-> Creates a variable "eg"
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Simulation ADE-L  Evaluate Results

Tools –> Calculator

Select

In Visualization&Anlaysis Window -> Marker -> Create Marker

Markers set to find the -1 gain
to determine noise margins. 

Inflexion point (max. abs. gain value)

Recommendation: Move derivation plot to new subwindow (RM-> Move to)
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Simulation ADE-L  Evaluate Results using Delta Markers

1. Marker -> Create Marker -> Point for
𝑑𝑣𝑜𝑢𝑡

𝑑𝑣𝑖𝑛
= −1

2. Marker -> Create Marker -> Point
(The two markers overlay at first "y = -1" point]

3. Move and edit second point marker to second "y = -1" 
4. Make point markers for x = 0 V and x= 3.3 V
5. Select marker pairs (use Ctrl) and choose Marker -> Create  Delta Marker
6. The dx-values are the logic margins

Select derivative trace

Show the logic margins

1.357 V
1.374 V

If we have more than one y-axis the markers can be assigned using RM over the marker -> assign to axis
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Tools -> Parametric Analysis

Select "temp" (There is nothing else when you start)!
Try the other entries! Here: -40°C to 80°C in 10° steps)

Simulation Parametric Analysis – Temperature (Built in)

Start ADE Test Editor: with RM over your test

Now we could repeat the logic margin evaluation
for the extrem temperatures
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Simulation Parametric Analysis – Global and Design Variables

Start here to create a design variable

Or start here to create a global variable.
It must be exported/backannotated to appear in test.

As an example we replace the fixed width of the PMOS transistor by a  "Pwidth" in the inverter schematic.
Open the schematic and change the "wtot" of the pmos transistor from fixed value t o "pwith"!

If there is only the testbench schematic open,
select inverter and press "E" (descend edit) to
open the inverter schematic!

Virtuoso XL uses "Global" and "Design" variables.
Design Variables are valid for the specified test only
Global variables are valid for all tests in the adexl-view
Global variables overwrite design variables with same name
Overwritten design variables are shown with a horizontal strike
It is possible (RM over design variable) to update a global variable
from a design variable
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Open object parameters (q)!
Replace fixed value by parameter!

Simulation Parametric Analysis – Using Variables

Simulation results

Start here for parametric simulation!
Start from Test Editor Window runs without
parametric variation (Default values used).

You may refine the simulation with a new set or range of pwidth-values
1,65 V
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2 ∙
𝐶𝑜𝑥2
2

2 ∙
𝐶𝑜𝑥1
2

𝐶𝑜𝑥2
2

𝐶𝑜𝑥1
2

Miller-Capacitor When to consider? 

 only, if 𝑽𝒊𝒏> 𝑽𝑺𝑷, resp. 𝑽𝒊𝒏>
𝑽𝑫𝑫

𝟐

Voltage change over C:  𝟐 ∙ 𝑽𝑫𝑫
𝐶𝑖𝑛 =

3

2
𝐶𝑜𝑥1 + 𝐶0𝑥2

𝐶𝑜𝑢𝑡 ≈ 𝐶𝑜𝑥1 + 𝐶0𝑥2

CMOS Inverter Capacitances and Delay

Real circumstances more complex:
Gate capacitances to drain, source, channel, bulk -> 
additional 𝐶𝑂𝑣𝑒𝑟𝑙𝑎𝑝, 𝐶𝑖𝑛 nonlinear: 

Originally the junction capacitance
between drain and bulk

In the range of 𝐶𝑜𝑥 if source and bulk
are interconnected

Nonlinear ~
𝟏

𝑽

𝐶𝑜𝑢𝑡

Region 𝐶𝐺𝑩 𝐶𝐺𝑺 𝐶𝐺𝑫 𝐶𝒊𝒏

off 𝐶𝑜𝑥 0 0 𝐶𝑜𝑥 + 2 ∙ 𝐶𝑜𝑣

NPO 0 1

2
∙ 𝐶𝑜𝑥

1

2
∙ 𝐶𝑜𝑥

𝐶𝑜𝑥 + 2 ∙ 𝐶𝑜𝑣

PO 0 -> 
2

3
∙ 𝐶𝑜𝑥 -> 0 2

3
∙ 𝐶𝑜𝑥 + 2 ∙ 𝐶𝑜𝑣

𝐶𝑜𝑣

AlPoly-Si

𝑉𝐷𝑆
𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al
𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+
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AlPoly-Si

𝑉𝐷𝑆𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al

𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+

AlPoly-Si

𝑉𝐷𝑆
𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al
𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+

AlPoly-Si

𝑉𝐷𝑆𝐺𝑁𝐷

p-Substrate

𝑉𝐺𝑆

−𝑉𝑆𝐵

Al

𝑆𝑖𝑂2𝑆𝑖𝑂2

𝑆𝑖𝑂2

𝑛+𝑛+
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𝐼𝐷 =
𝛽𝑛
2

𝑉𝐷𝐷 − 𝑉𝑡ℎ𝑛
2 =

𝐾𝑃𝑁

2

𝑊

𝐿
𝑉𝐷𝐷 − 𝑉𝑡ℎ𝑛

2 =
170

2

µ𝐴

𝑉2
∙
1µ𝑚

0.35µ𝑚
∙ 3.3𝑉 − 0.5𝑉 2= 0.68 𝑚𝐴

𝑅𝑛 = 𝑅𝑝 =
𝑉𝐷𝐷

𝐼𝐷
=

3.3𝑉

0.68𝑚𝐴
= 4.85 𝑘Ω

Output resistance of FET for charge reversal

𝐶𝑖𝑛 =
3

2
𝑊 ∙ 𝐿 ∙ 𝐶′𝑜𝑥

𝐶𝑜𝑢𝑡 = 𝑊 ∙ 𝐿 ∙ 𝐶′𝑜𝑥

𝑡𝑝𝐻𝐿 = 𝑡𝑝𝐿𝐻 = 0.7 ∙ 𝑅𝑎 ∙ 𝐶𝑖𝑛𝑛 + 𝐶𝑖𝑛𝑝 + 𝐶𝑜𝑢𝑡𝑛 + 𝐶𝑜𝑢𝑡𝑝

𝑡𝑝𝐻𝐿 = 𝑡𝑝𝐿𝐻 = 0.7 ∙ 𝑅𝑎 ∙ 𝐶′𝑜𝑥 ∙
5

2
𝑊𝑛𝐿𝑛 +𝑊𝑝𝐿𝑝

𝑡𝑝𝐻𝐿 = 𝑡𝑝𝐿𝐻 = 0.7 ∙ 4.85𝑘Ω ∙ 4.5
𝑓𝐹

µ𝑚2 ∙
5

2
1 + 3.2 µ𝑚2 = 160 ps

Single transistor at 𝑉𝐷𝐷 with input voltage at 𝑉𝐷𝐷

Capacity and time constant-> Delay time (50%-cross distance)

𝐶𝑖𝑛 = 4.5
𝑓𝐹

µ𝑚2
∙
3

2
1 + 3.2 µ𝑚2 = 28.35 fF

𝐶𝑜𝑢𝑡 = 4.5
𝑓𝐹

µ𝑚2
∙ 1 + 3.2 µ𝑚2= 18.9 fFnext gate

(+ wire capacitances)

CMOS Inverter Capacitances, Output Resistance and Delay
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Simulation   Transient Analysis

Replace the vdc-source by a vpulse-source. (It would be possible to use this from scratch even for dc-simulation!)

Try another parametric simulation 
(transient) with Load Capacitance as a 
parameter!

Period

Pulse width

Rise time Fall time

Voltage2

Voltage1

Delay

t=0

How to find proper time values?
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Simulation   Transient Analysis

Oops!, looks strange …
1pF load is too much for our small gate 

Changed load to 80 fF
Compare with data sheet of 
ams standard cell next page!

falltime: 1.555ns-1.1545ns=400 ps
risetime: 2.2404ns-2.0601ns=180 ps
delay(inp rise): 1.3324ns-1.005ns=327 ps
delay(inp fall): 2.1328ns-2.015ns=118 ps

To display cross points: RM on marker line > Intercepts -> On
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Simulation   Transient Analysis

Try another parametric simulation with
Load Capacitance as a parameter!
Compare results with a given cell from AMS!

Uups!, explain the negative value!
fall time

propagation
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Simulation   Transient Analysis

Using Calculator and functions to show delay, fall time, rise time 

Calculator works with stack in RPN

Input and output from voltages transient simulation
VT("/in"), VT("/in") used in the function "delay"

To wave
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Similar to the input-output-delay you may use the risetime and falltime functions

Simulation Transient Analysis

Parametric simulation of delays vs. load capacity
Input transition time 10 ps

propagation delay rise to fall

rise time

fall time

falltime: 1.555ns-1.1545ns=400 ps
risetime: 2.2404ns-2.0601ns=180 ps
delay(inp rise): 1.3324ns-1.005ns=327 ps
delay(inp fall): 2.1328ns-2.015ns=118 ps
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Layout Start and Generate from Schematic

Replace all the Variables in the design with fixed values.  
Variables have their scope in simulation only.
Variables in the testbench are not affected, because they will not be involved in the layout. 

In Schematic Editor: Launch -> Layout XL
In Layout XL: Connectivity -> Generate ->All From Source  

Generates a layout with all instances placed outside a rectangle (estimated cell boundary) 

Text is used to recognize 
ports correctly.

Fold the PMOS (2 gates)

Here we may select the cell boundary:
origin, width, height (0:0, 6, 20]
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Point 0,0

Edit ->  Stretch
Tools->  Create Measurement*

Fix it using RM -> 

Layout Floorplaning

Suggested cell area
20µm x6 µm cell

Tools -> Clear All Measurements*m
Create -> Shape -> Rectangle

+

When moving pins include all parts. 
Best practice: Snap to the little "+"!

To see all layers: Options -> Display -> Display Levels -> Set "stop" to 32        (Shift-f) Save to ~/.cdsenv

*Ruler in older versions

F3 opens move options (e.g. orthogonal, all angels etc.) 
(F3 opens options for all commands)

Don't have Bulk ?
Delete both transistors in layout.
Open schematic and change transistor property there (add substrate contact).
In Layout XL use Connectivity -> Update Components and Nets.

If you have lost prBoundary you can generate a new one by:
Create -> P&R Objects -> P&R Boundary
(prBoundary is an object, not a simple shape!)

Way to change something in the schematic
and make it actual in Layout 

In Layout-XL, 
not in Layout-L !
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actual layer

visible/selectable

Create -> Shape -> Rectangle

Input with mouse:
First corner 0:0
Opposite Corner 6:3
or input in CIW:
0:0 enter  -> 6:3 enter

0:0

6:3

Layout Edit

Edit -> Copy 

0:17

6:20
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Layout (Automatic) Pin Placement (optional)

In Layout XL:  Place -> Pin Placement

Form offers a chice to place pins at top (vdd!) bottom (gnd!) left (inputs) and right (outputs)
For top (vdd!) and bottom (gnd!) the pins can be extended to rails with the width up to the cell width
and a defined hight. 

Pin 6x3µm top
of the cell

Signal pins may be placed left or right first, then change the placement to "any" and move
to the appropriate location. As long as they have the attribute "left" or "right" they are locked to the edge.
Other way : Properties -> Placement Status -> Unplaced

Select Rail first
then define size
then egde
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Layout (Automatic) Placement of Instances (optional)

For a simple inverter with two tansistors it is easy to identify the transistors and to place them in an appropriate pattern in the layout.
Fore more complex designs some kind of automatic placement may be used. Here shown for an operational amplifier (OPA) and
the placement option "like schematic". Helps to identify the instances/parts.

Instances unplaced
(Pins already placed

Place -> Analog -> Place Like Schematic



POLY1

MET1

MET1-rail for vdd!

MET1-rail for gnd!

gnd!, vdd! ->    Exclamation marks: 
Global signal names valid through design hierarchy

PIN in MET1

PD_C p-Substrat-Metal1 VIA

ND_C n-Well-Metal1 VIA

P1_C Poly1-Metal1 VIA

n-Well(NTUB) extended for vdd connection
and merging with adjacent cells

-0.5:10 -> 6.5:20.5
Remember usage in (flipped) raws

Cell Layout

Hight: 20 µm, Width: 6µm

Cell hight of ams digital standard cells 13 µm
Simple Inverter 30 µ𝑚2

To consider (design rules):
Poly1: width ≥ 0.35µ, space ≥ 0.45µ
Metal1: width ≥ 0.5µ, space ≥ 0.45µ
Metal2: width ≥ 0.6µ, space ≥ 0.5µ
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pmos-Transistor
in n-well (folded)

must enclose vdd!-pin

must enclose gnd!-pin

nmos-Transistor

Transistors n-Well

RM and Via up/down
to change layer

F3 to change
wire width



Creating VIAs:
PD_C   :   p-Substrat-Metal1
ND_C   :   n-Well-Metal1
P1_C    :   Poly1-Metal1
P2_C    :   Poly2-Metal1
VIA1_C :   Metal1-Metal2
VIA2_C :   Metal2-Metal3
VIA3_C :   Metal3-Metal4

Layout of single contact predefined. Do not change!
Number and alignment variable. Using "Compute from
Shape(s)" fills area with appropriate number of contacts.

Stacked VIAs connecting more than
two layers available:

Layout - VIAs
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Make them for the power stripes before
routing of wires.

}
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Cell Layout – Design Rule Driven Design -DRD (optional)

To avoid design rule violations when moving instances or wiring we can switch on the DRD.

Options -> DRD-Edit

"Enforce" stops edit action (route a wire, move an element) 
if a design rule is violated.

You must select one mode here!

"Notify" writes a warning if a design rule is violated.

"Post-Edit" sets markers only if a design rule is violated.
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Cadence  Layout - LVS

Compare Layout Versus Schematic
Assura ->  Run LVS

Necessary for QRC parasitic extraction That's what we want to see!

wait!

ams says: "Do NOT use the resimulate_extracted switch because 
in that case substrate shorts (soft connections between 
different nets via substrate) might not be found correctly!

Dann fehlen im av_extracted die design layer
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Cadence  Layout - DRC

Assura -> Run DRC

Set these switches to avoid
some messages (see below!).
What does "Coverage" mean?

Here you may open the 
rule set file for information.
Contains all the rules like
distances, overlap, min. width
et cetera.

That's what we would like to see!
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Cadence  Layout – DRC  with Errors remaining

View -> Error Report

Browse Errors (if multiple)

Example for an Error Message:
Here: Pin is not fully covered by metal

Position in Layout

Position in Layout

Violated Rule

Violated Rule

Solutions:
Extend wire to the right or
add a rectangle in MET1 covering the Pin

Browse violated rules
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Cadence  Layout - DFM

Assura -> Run DRC

Errors because we did not use 
some layers.
Interesting for a top layout.

OPtion: extended ruleset DFM:
Design For Manufacturing ->

Coverage of all but upper metal 
layer et cetera.

no switches!
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Cadence  Layout - ERC

Electrical rule check is included in DRC.
There is no separate rule check in the ams-HITkit.

Starting ERC with Assura -> Run ERC opens a form similar to DRC
with no technology selected and either rule files.

Up to now no verification for this.
Separate ERC-usage found nowhere.
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Cadence  Layout – QRC – Parametric Extraction

Coupled C:  net to net (signals)
Decoupled C: net to power and ground only 

use gnd! or vcc!

no changes

RC

QRC -> Run Assura Quantus -QRC

wait!

seit 6.1.7 dazwischengeschaltet
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Cadence – QRC – Extracted view

pico 10−12

femto 10−15

atto 10−18

zepto 10−21

Launch -> Plugins ->Parasitics : New Tab "Parasitics"
Parasitics -> Setup Parasitics (gnd! and vdd! as reference nodes)

In Schematic or av_extracted view:
Launch -> Parasitics : New Tab "Parasitics"
Parasitics -> Report Parasitics -> net : Select with cursor
In Schematic Parasitics -> Show Parasitics :  Lumped values

Viewing parasitics may be interesting.
More important is their use in postlayout simulation.
They will be included in simulation netlists.

Zoom

Try also: net to net
terminal to terminal (r)

Open View "av_extracted" in Library Manager
Maybe you must select all layers (up to 32) in Options -> Display once more
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Cadence – QRC – Post-Layout Simulation (ADE-L/XL)

Open testbench (schematic)
Save as a new testbench and open it.
Copy the inverter and its load.

We need different models for the UUT (inverter)
• Original schematic
• Netlist with extracted parasitics.Or in CIW:

File -> New -> Cellview

In Schematic Editor:

Launch -> Plugins -> Hierachy Editor

In new Tab "Hierarchy-Editor"

Edit Configuration

Begin here!
Template will fill the form
in background.

Use different netnames for
the output signals!
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Cadence – Post-Layout Simulation (ADE-L/XL)

55

Parasitics

Replace (use RightMouse -> Set Instance View ) schematic by av_extracted

Now we have two different models for the two Inverters.
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Cadence – Post-Layout Simulation - Result

OK, delay increased by some ps

OK, no visible change
Shown for 𝑪𝑳𝒐𝒂𝒅= 4 fF. Less difference for higher load.
(if 𝑪𝑳𝒐𝒂𝒅 is higher parasitic capacitors have less influence)

20%

50%

80%

40ps

30ps

To perform simulation see slides above 
from "Simulation ADE GXL  Start"  

Open the configuration in Library Manager



17.12.2018 IGS / Uni-Rostock 57

Layout 3D View

GDS3D from University of Twente, NL

Needs a technology file (layer thickness, pitches). Generated for AMSC35B4 from process parameters.
Needs initialization for Cadence integration, but may be used standalone. 

Automatic initialization does not work yet. For manual initialization observe the last output
after CIW start.

With a layout opened we can make a GDSII-Stream and
run the GDS3D tool.  ICD - Tools

In the GDS3D-tool use F1 to see the (game like) usage.

Do not use the normal streamout from CDW (File -> Export -> Stream) because GDS3D
uses a separate directory for the gds-File!

ICD is simply Integrated Circuit Design group
at Twente University)
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Layout 3D View

MET1 display deselected.
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Advanced Simulation

Monte Carlo simulation using matching parameter

Open testbench schematic -> Launch ADE-XL -> existing view ADE-XL  (assuming we have such a view already)

Use one of the tests from the normal schematic simulation

Here we use the dc-analyses to investigate the transfer characteristic.

RM over name of the test (e.g. test:name:19  "Open Test Editor"

With Setup-> Model Libraries: Select cmosmc for the transistors (we have only transistors here we could select …mc for other parts)

Dubbleclick here to open choices

…mc – Monte Carlo
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Advanced Simulation

Monte Carlo simulation using matching parameter

We want to see the switching point (𝑉𝑜𝑢𝑡 = 𝑉𝑖𝑛) and the noise margin for "low" and "high" output.

We investigate the following expressions:

Switching point:  cross(VDC("/vout") 1.65 1 "either" nil)
Low logic value noise margin: cross(deriv(VDC("/vout")) -1 1 "either" nil)
High logic level noise margin: (3.3 - cross(deriv(VDC("/vout")) -1 2 "either" nil)) 

To set the output expressions:  "add expression"  - > open calculator

Difference to vdd (3.3 V)Difference to gnd (0 V)



K.-P. Kirchner, Uni Rostock, Institut GS

cross gives the vin-value if deriv(vout)= -1
first time 

For the LOW noise margin we use the "cross"-value, for the HIGH noise margin we use 3.3-"cross"-value

Advanced Simulation

Monte Carlo simulation using matching parameter

Here RM and "add expression"

Select DC-signal vout
from schematic

Use the deriv and cross functions
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Advanced Simulation

Monte Carlo simulation using matching parameter

n simulation runs with
random values

It is possible to vary selected parts only

See it running in the buttom left corner

Process: Doping, thickness
Mismatch: Doping: local variation (number of charges differs statistically)

Geometry: Edge uncertainties
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Advanced Simulation

Monte Carlo simulation using matching parameter

Result: Histogram

Distribution of noise margins (mismatch only)

switching point

low level margin high level margin

Number of intervals,
plots show 20 intervals

Select expressions
to display here!
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Distribution of noise margins (combined mismatch and process variaton)

Advanced Simulation

Monte Carlo simulation using matching parameter

Switching Point

High level marginLow level margin
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Advanced Simulation

Monte Carlo simulation and yield prediction

Define (realistic) specs for characteristics: Inverter: 𝑉𝑖𝑛𝐻𝐿, 𝑉𝑚𝐻𝑖𝑔ℎ, 𝑉𝑚𝐿𝑜𝑤 …

Set Options for Monte Carlo Simulation: 

Recommended to
have enough samples

Better than simple "Random".
Better covering of the
n-dimensional input scope

From: https://community.cadence.com/cadence_blogs_8/b/cic/posts/the-art-of-analog-design-part-2-monte-carlo-sampling

non covered
area
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Advanced Simulation

Monte Carlo simulation and yield prediction

Set specs in adexl outputs window:   low level margin > 1.2 V
high level margin > 1.2 V
1.50 V < switching voltage < 1.80 V
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Advanced Simulation

Monte Carlo simulation and yield prediction

Be aware that we did not change opereating environment (temperature, supply voltage)

Next slide!
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Monte Carlo simulation and yield prediction

𝐶𝑝 und 𝐶𝑝𝑘 Process Capability Statistics

𝐶𝑝 shows the relation beetwen Engeneering Tolerance (specs) to the Natural 

Tolerance (process) for a process with a distribution centered beetween
specifications. For the Natural Tolerance the 6𝜎-interval  ±3𝜎 is commonly used

𝐶𝑝 =
𝑈𝑆𝐿 − 𝐿𝑆𝐿

6𝜎

what the designer wants (specs)

what the process can deliver with high certainty

𝐶𝑝𝑘 =
𝑚𝑖𝑛𝑖𝑚𝑢𝑚 𝑈𝑆𝐿 − µ , (µ − 𝐿𝑆𝐿)

3𝜎

Upper
Spec
Limit

Lower
Spec
Limit

Mostly the distribution is not centered and the corrected value is used (maybe used
for centered distribution as well):

If 𝐶𝑝𝑘 = 1 then 99.73% of the samples will meet specs, for 𝐶𝑝𝑘 = 2: 99.9999998%

Mittelwert

"Recommended": Values beetween 1.25 to 2.0 dependend on safety demands
> 2.5 area reduction possible? cost! 

𝐶𝑝 =
𝑈𝑆𝐿 − µ

3𝜎

𝐶𝑝 =
µ − 𝐿𝑆𝐿

3𝜎

upper or lower
limit only
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Advanced Simulation

Corner Simulation

FEOL (front end of line) Corners:  Transistors   n-channel , p-channel

TT : typical n-channel- and p-channel-FETs
SS : slow n-channel-FET, slow p-channel-FET 
SF : slow n-channel-FET, fast p-channel-FET
FS : fast n-channel-FET, slow p-channel-FET
FF : fast n-channel-FET, fast p-channel-FET

BEOL (back end of line) Corners:  Wires

transistors affected in similar

"Fast" means "best":
-thin oxide
-smaller length
-higher width

Corners affect not only speed but also transfer characteristics (dc-dc)

Temperature, Voltage

all processes used for individual parts (transistors, resistors)

all processes after making parts -> wires, vias

TM: typical values - corresponds to TT
WS : worst slow – slow n and slow p corresponds to SS
WP: worst power – fast n and fast p  corresponds to FF
WO : worst One – slow n, fast p  corresponds to SF
WZ: worst Zero – fast n, slow p corresponds to FS

ams (and others):
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Here we can see all the selected corners

Modification of temperature

Corner Simulation – Corner Preparation

Keep in mind!
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Corner Simulation – Import Corners
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Do NOT select!

WO/0°C WZ/80°C

Corner Simulation – Run and Results

Press to see waveforms!
Not shown here.
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Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
Inverter,  2-Input-NAND,  2-Input-NOR

𝑉𝐷𝐷 = 3.3𝑉
𝑉𝑡ℎ𝑛 = 0.48V
𝑉𝑡ℎ𝑝 = 0.67𝑉

𝐾𝑃𝑛 = 170
µ𝐴

𝑉2

𝐾𝑃𝑝 = 58
µ𝐴

𝑉2

(𝑡𝑜𝑥 = 7.6 𝑛𝑚)

Calculate the geometry in ( Τ𝑊 𝐿-ratio for p- und n-transistors) so that you get a good compromise for the switching point
and noise margin for the cases:
- Both inputs change at the same moment (connected)
- One input is preassigned to a fixed value so that the second one causes output change. (May be different for both inputs!)

Switching point should be near
𝑉𝐷𝐷

2
for all cases.

Design (schematic, layout) a 2-Input-NAND or a 2-Input-NOR  using short channel length transistors (0.35µ) 
or long channel length transistors (3.5µm]. Selection of the specific design is done with the tutor. 

Cell hight shall be 20 µm.

From Simulation (including postlayout) find out the following values: 
Switching points and noise margin for the different cases at the two inputs.
Delay times (50%), falltime, risetime (20%-80%) dependend on load capacitance (4.. 100 fF) and temperature (-40 to 80°C).
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𝛽𝑛
2

𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑛
2 =

𝛽𝑝
2

𝑉𝐷𝐷 − 𝑉𝑖𝑛𝑆 − 𝑉𝑡ℎ𝑝
2

𝛽𝑛 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑛 = 𝛽𝑝 𝑉𝐷𝐷 − 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑝

𝑉𝑖𝑛𝑆𝑃 =

𝛽𝑛
𝛽𝑝

∙ 𝑉𝑡ℎ𝑛 + 𝑉𝐷𝐷 − 𝑉𝑡ℎ𝑝

1 +
𝛽𝑛
𝛽𝑝

𝛽𝑛
𝛽𝑝

=

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑛

2

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑛

2

𝛽 = 𝐾𝑃 ∙
𝑊

𝐿
𝑚𝑖𝑡 ∶ 𝐾𝑃𝑁 = 3 ∙ KPP

Für 𝑉𝑖𝑛𝑆𝑃 =
𝑉𝐷𝐷

2
Dissolve for𝑉𝑖𝑛𝑆𝑃:

At the switching point both transistor-pairs are in the pinch-off state and passed
by the same current :  

𝛽𝑛
2

𝑉𝑖𝑛𝑆𝑃 − 𝑈𝑡ℎ𝑛
2 =

𝛽𝑝

2
𝑉𝐷𝐷 − 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑝

2

But: There is a difference in the number of involved switching transistors
for the different input cases!

Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
Inverter,  2-Input-NAND,  2-Input-NOR

Common Equation for CMOS-Inverter:

𝑊
𝐿

𝑝

𝑊
𝐿

𝑛

≈ 3

𝑉𝑡ℎ𝑝

𝑉𝑡ℎ𝑛PMOS in NPO

NMOS in NPO

Both in PO

𝑉𝑖𝑛𝑆𝑃
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Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
Inverter,  2-Input-NAND,  2-Input-NOR

NAND-Gate

𝛽𝑛𝑔𝑒𝑠

𝛽𝑝𝑔𝑒𝑠
=

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑛

2

𝑊
𝐿 𝑛

𝑊
𝐿 𝑝

=
4

3
∙

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑈𝐵
2
− 𝑉𝑡ℎ𝑛

2

𝛽𝑛𝑔𝑒𝑠 = 𝐾𝑃𝑁 ∙
1

2

𝑊

𝐿
𝑛

𝛽𝑝𝑔𝑒𝑠 = 𝐾𝑃𝑃 ∙ 2
𝑊

𝐿
𝑝

𝐾𝑃𝑁 = 3 ∙ KPP

For𝑉𝑖𝑛𝑆𝑃 =
𝑉𝐷𝐷

2
when both inputs change:

𝑊
𝐿 𝑛

𝑊
𝐿 𝑝

=
4

3
∙

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑛

2

=
4

3

1.65 − 0.7

1.65 − 0.5

2

= 0.908

One transistor of double length

One transistor of double width

𝑊
𝐿

𝑝

𝑊
𝐿

𝑛

= 1.1
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𝛽𝑛
2

𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑛
2 =

𝛽𝑝
2

𝑉𝐷𝐷 − 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑝
2

𝛽𝑛 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑛 = 𝛽𝑝 𝑉𝐷𝐷 − 𝑉𝑖𝑛𝑆𝑃 − 𝑉𝑡ℎ𝑝

𝑈𝑒𝑆 =

𝛽𝑛
𝛽𝑝

∙ 𝑉𝑡ℎ𝑛 + 𝑉𝐷𝑆11 + 𝑉𝑡ℎ𝑛𝐵 − 𝑉𝑡ℎ𝑝

1 +
𝛽𝑛
𝛽𝑝

𝛽𝑛
𝛽𝑝

=

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑛 − 𝑉𝐷𝑆11

2

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑝

𝑉𝐷𝐷
2

− 𝑉𝑡ℎ𝑛 − 𝑉𝐷𝑆11

2

For 𝑉𝑖𝑛𝑆𝑃 =
𝑉𝐷𝐷

2

Lower transistor in NAND during switching phase:

𝛽𝑛𝑔𝑒𝑠 = 𝐾𝑃𝑁 ∙
𝑊

𝐿

𝛽𝑝𝑔𝑒𝑠 = 𝐾𝑃𝑁 ∙
𝑊

𝐿
𝐾𝑃𝑁 = 3 ∙ KPP

One p-transistor is off and remains off.
One n-Transistor is on and remains on.
Only an inverter is switching.

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙

1.65 − 0.7

1.65 − 0.5 − 0.236

2

= 0.36

𝑊
𝐿

𝑝

𝑊
𝐿

𝑛

= 2.78

𝑊
𝐿

𝑛

𝑊
𝐿

𝑝

=
1

3
∙
1.65 − 0.7

1.65 − 0.5

2

= 0.23

𝑊
𝐿

𝑝

𝑊
𝐿

𝑛

= 4.44

Interesting, but we can implement one geometry only
and must configure a compromise. 

See if the values are acceptable with regard to noise margin.
Try to change W/L ratios to find a compromise.

Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
2-Input-NAND,  2-Input-NOR
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𝑉𝑖𝑛𝑆𝑃 =

𝛽𝑛
𝛽𝑝

∙ (𝑉𝑇ℎ𝑛 + 𝑉𝐷𝑆11) + 𝑉𝐷𝐷 − 𝑉𝑡ℎ𝑝

1 +
𝛽𝑛
𝛽𝑝

𝑉𝑖𝑛𝑆𝑃𝑢 =

3
1.1 ∙ 0.5𝑉 + 3.3𝑉 − 0.7𝑉

1 +
3
1,1

= 1.29 𝑉

Using the Relation for switching both
transistors Τ𝑊 𝐿 − 𝑟𝑒𝑙𝑎𝑡𝑖𝑜𝑛 = 1.1:

Τ𝑾 𝑳 −
𝑹𝒆𝒍𝒂𝒕𝒊𝒐𝒏PMOS/NMOS

𝑽𝒊𝒏𝑺𝑷 when switching
both inputs [Volts]
and difference to 𝑽𝑫𝑫

𝑽𝒊𝒏𝑺𝑷 only "upper
NMOS" switching [Volts]
and difference to 𝑽𝑫𝑫

𝑽𝒊𝒏𝑺𝑷 only "lower
NMOS" switching  
[Volts]
and difference to 𝑽𝑫𝑫

1.1 1.65    /  1.65 1.36    / 1. 94 1.30   /  2.00

2.2 1.83    / 1.47 1.55    / 1.75 1.47  /  1.83

3.3 1.92    / 1.38 1.66    / 1.64 1.58  /  1.72

4.4 1.98    / 1.32 1.74    / 1.56 1.66  /  1.64

Switching input voltage 𝑽𝒊𝒏𝑺𝑷 for different Τ𝑊 𝐿 - relations of the transistors from Simulation

Not considered:
Conducting NMOS has a resistance (𝑈𝐷𝑆 > 0)
Body-/Backgate-Effect (𝑈𝑇ℎ dependent of subtrate voltage)

𝑉𝑖𝑛𝑆𝑃𝑜 =

3
1.1 ∙ 0.5𝑉 + 0.236𝑉 + 3.3𝑉 − 0.7𝑉

1 +
3
1,1

= 1.38 𝑉

𝐾𝑃𝑁/𝐾𝑃𝑃

൘
𝑊

𝐿
𝑝

𝑊

𝐿
𝑛

Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
2-Input-NAND,  2-Input-NOR
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Lab: Circuit Design using Cadence and AMS CMOS 0.35µ Technology
2-Input-NAND,  2-Input-NOR

Starting from the inverter schematic:

You may open the inverter schematic as the origin for the new design.

Then create a new schematic cellview (from CDW or Library Manager).  File -> New -> Cellview

When you have the new empty schematic and the inverter schematic side by side you can copy the
inverter circuit or parts of it to the new schematic.

Use copy: "c" -> select the desired part using the left mouse button 
-> click on the selected part 
-> drag to the new place (may be the same schematic window or the new one)

Copy object from one schematic window to another: In target no command should be active!  (Use ESC sometimes!)

Edit the new schematic to build the NAND or NOR design.

Practical hint to safe time:

You may proceed in the same manner for the testbench.
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2-input-NAND Schematic and associated Testbench

L=0.35 µ
W=2 µ

L=0.35 µ
W=1 µ
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From Schematic

automatic, linear, logarithmic

Design Variables
Simulation Outputs

Create/Edit analyses

Delete selected analyses

Plot

Run enabled analyses
Stop

2-Input-NAND,  2-Input-NOR – Use steps as before in inverter simulation
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From Schematic

2-Input-NAND,  2-Input-NOR – Use steps as before in inverter simulation
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Transfer characteristics and noise margin for 2-Input-CMOS-NAND-Gate 

𝑑𝑉𝑜𝑢𝑡
𝑑𝑉𝑖𝑛
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Transfer characteristics of 2-input-NAND-Gates
from AMS-0.35µ-library with 𝐿𝑁𝑀𝑂𝑆,𝑃𝑀𝑂𝑆 = 0.35µ, 𝑊𝑁𝑀𝑂𝑆 = 1.325µ,𝑊𝑃𝑀𝑂𝑆 = 2.1µ
and 
self-made  gate with 𝐿𝑁𝑀𝑂𝑆,𝑃𝑀𝑂𝑆 = 0.35µ, 𝑊𝑁𝑀𝑂𝑆 = 1.0µ,𝑊𝑃𝑀𝑂𝑆 = 1.6µ
(Characteristics for switching top N-transistor only not shown, always between bottom and both 
cases)

Transfer characteristic for 2-Input-CMOS-NAND-Gates
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Simulation of 4-input-NAND from 0.35µm library

D-input uses NMOS-transistor nearest to GND, A-
input is top NMOS-transistor. 
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Transfer characteristic of 4-input-NAND-Gate from AMS-0.35µ-library
with 𝐿𝑁𝑀𝑂𝑆,𝑃𝑀𝑂𝑆 = 0.35µ 𝑊𝑁𝑀𝑂𝑆 = 1.05µ,𝑊𝑃𝑀𝑂𝑆 = 1.4µ
Leftmost line for switching lowest (nearest to ground )nmos-transistor only, 
rightmost line for all 4 inputs switched simultaneously

o_d

o_abcd

4-Input-NAND-Gate from AMS-0.35µ-library
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Cadence  Transfer Library Content to a new Library

new
old library

Edit -> Copy Wizard

Create before!
Enter path!

When we will have finished copying we can delete the old libraries entry.
We get a warning because we are coying the library completely.
Acknowledge with "Overwrite All" !

Use Cadence tools always! DO NOT copy in linux.


